我的位置:首页 > 操作系统>Linux

急 eWebEditor在Linux下不能使用。解决方案

时间:2015-01-17 09:18:25 来源:互联网 作者: 神秘的大神 字体:

急! eWebEditor在Linux下不能使用。
各位大哥。之前一直在windows   下使用ewebeditor,使用情况良好。。
最近我把这个系统用在linux下。。linux   下jsp环境已经配置好。但是把ewebeditor移到linux下面,发现居然用不了。出现这个错误:
type   Exception   report

message  

description   The   server   encountered   an   internal   error   ()   that   prevented   it   from   fulfilling   this   request.

exception  

org.apache.jasper.JasperException
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:372)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


root   cause  

java.lang.NullPointerException
org.apache.jsp.eWebEditor_jsp._jspService(eWebEditor_jsp.java:249)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:324)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


note   The   full   stack   trace   of   the   root   cause   is   available   in   the   Apache   Tomcat/5.0.28   logs.

估计是class中的bean没有初始化造成的。。请问。大伙有没有见到过这样的问题?
这个问题又该怎么解决呢?   十分感谢啊。。。分不多。请大家帮个忙。急啊。。

------解决方案--------------------
建议换为fckedit吧,开源的,功能强大。
------解决方案--------------------
类初始化的时候要读到button.xml,style.xml两个文件,看看是不是这出的问题.
------解决方案--------------------
这个错误可能不是eWebEditor的,应该是配置文件中windows和linux的路径表示不一致
------解决方案--------------------
我以前也碰到过这样的问题,最后解决不了只好换FCKeditor了
我的异常网推荐解决方案: The server encountered an internal error () that prevented it from fulfilling this request.,http://www.myexception.cn/java-web/317.html